CADDIT CAD CAM CNC Software - download AutoCAD compatible design software progeCAD Alibre T-FLEX and more
CADDIT Website Knowledge Base Search:
CL

progeCAD Help

CR
Welcome to progeCAD
Working with progeCAD
Command Reference
CAD System Variables
Programming progeCAD
Full Index (caution - 400kb)

Further Links:

Download progeCAD
Register progeCAD

Learning

T-FLEX PLM tutorial (PDF)
progeCAD IntelliCAD and AutoCAD training 
CATIA 2D 3D design tutorial
Alibre CAD/CAM basic tutorial

Resources

Educational CAD Software Solutions
Python scripting for DOS and Windows
Other free software downloads
CADDIT CAD CAM Forum Australia
__

Opening damaged drawings

Files can become damaged for many reasons. For example, if you are working on a drawing during a power outage, a system crash, or a hardware failure, your drawing file may become damaged. progeCAD allows you to open and check damaged files to attempt file recovery.

Recovering a file attempts to open one of the following file types:

  • Standard drawing files with a .dwg extension.
  • Drawing Exchange Format files with a .dxf file extension.
  • Design Web Format files with a .dwf file extension.
  • Drawing templates with a .dwt file extension.

You can also audit any open file to check it for errors. You specify whether you want progeCAD to fix any errors that are found automatically. progeCAD fixes as many errors as possible and any errors that cannot be fixed are reported as "Ignored" in the Prompt History window.

To open a damaged file

  1. Use one of the following methods:
    • Choose File > Recover.
    • Type recover and then press Enter.
  2. In Files of Type, choose the type of file you want to recover.
  3. Choose the directory containing the damaged file.
  4. Choose the damaged file you want to recover.
  5. Click Open.

If you want to check all drawings for errors automatically when you open them, choose Tools > Options > General tab and mark the check box for Open Drawings using Recover.

To check a drawing file for errors

  1. With the drawing open that you want to check, do one of the following:
    • Choose File > Audit.
    • Type audit and then press Enter.
  2. Choose whether you want progeCAD to fix any found errors automatically, and then press Enter.

NOTE If the AUDITCTL system variable is set to On and errors are found during a file recovery or audit, an ASCII file is created that describes the audit. The ASCII file is saved in the same folder as the audited drawing and has the same name as the drawing file, but with an .adt extension.


CADDIT® is a registered trademark in Australia. All Rights Reserved. Comments concerning the content of this site should be addressed to our webmaster. progeCAD is a trademark of ProgeCAD srl. Autodesk® and AutoCAD® are both registered trademarks or trademarks of a third party, and used only for comparison purposes. All other trademarks, trade names or company names referenced herein are used for identification only and are the property of their respective owners. Legal and Terms of Use. Google. Find us on Google+.