CADDIT CAD CAM CNC Software - download AutoCAD compatible design software progeCAD Alibre T-FLEX and more
CADDIT Website Knowledge Base Search:
CL

progeCAD Help

CR
Welcome to progeCAD
Working with progeCAD
Command Reference
CAD System Variables
Programming progeCAD
Full Index (caution - 400kb)

Further Links:

Download progeCAD
Register progeCAD

Learning

T-FLEX PLM tutorial (PDF)
progeCAD IntelliCAD and AutoCAD training 
CATIA 2D 3D design tutorial
Alibre CAD/CAM basic tutorial

Resources

Educational CAD Software Solutions
Python scripting for DOS and Windows
Other free software downloads
CADDIT CAD CAM Forum Australia
__

Understanding the menu compatibility

MNU files are menu files created by all AutoCAD releases, and MNS files are included in AutoCAD Releases 13, 14, and 2000. progeCAD reads both file formats, even when menu macros include AutoLISP code. This feature allows you to continue using your existing AutoCAD menus.

progeCAD support of specific sections in AutoCAD MNU and MNS files

Menu section Definition progeCAD support
***POP0 Cursor menu Supported
***POPn Menus Supported
***AUXn Auxiliary menus Not supported
***BUTTONn Button menus Not supported
***ICON Icon menus Not supported
***SCREEN Screen menus Not supported
***TABLETn Tablet menus Not supported

To see how progeCAD reads AutoCAD menu source files

  1. Type menu and then press Enter.
  2. Under Files Of Type, select AutoCAD Menu File (mnu).
  3. In the Open Menu dialog box, go to the AutoCAD Support folder and select the Acad.mnu file (or Acad.mns for Releases 13 and 14).
  4. To load the AutoCAD menu file into progeCAD, click Open.
  5. The progeCAD menu bar now looks identical to the AutoCAD menu bar.
  6. To see how it works, choose File > Open and Draw > Line.
  7. To restore progeCAD to its default menu, choose Tools > Customize, and then click the Menus tab.
  8. To reverse the changes you made, click Reset.
  9. To restore the progeCAD default toolbars, choose Tools > Customize.
  10. Click the Toolbars tab.
  11. To reverse the changes you made, click Reset.

Customizing menus

Loading menu files

Saving menu files

Setting the experience level for menus

Starting commands using menus

Add a command to a menu

Create a new menu

Delete a menu item

Import a menu file

Load a menu file

Rename a menu item

Save the current menu to a file

CADDIT® is a registered trademark in Australia. All Rights Reserved. Comments concerning the content of this site should be addressed to our webmaster. progeCAD is a trademark of ProgeCAD srl. Autodesk® and AutoCAD® are both registered trademarks or trademarks of a third party, and used only for comparison purposes. All other trademarks, trade names or company names referenced herein are used for identification only and are the property of their respective owners. Legal and Terms of Use. Google. Find us on Google+.