CADDIT CAD CAM CNC Software - download AutoCAD compatible design software progeCAD Alibre T-FLEX and more
CADDIT Website Knowledge Base Search:
CL

progeCAD Help

CR
Welcome to progeCAD
Working with progeCAD
Command Reference
CAD System Variables
Programming progeCAD
Full Index (caution - 400kb)

Further Links:

Download progeCAD
Register progeCAD

Learning

T-FLEX PLM tutorial (PDF)
progeCAD IntelliCAD and AutoCAD training 
CATIA 2D 3D design tutorial
Alibre CAD/CAM basic tutorial

Resources

Educational CAD Software Solutions
Python scripting for DOS and Windows
Other free software downloads
CADDIT CAD CAM Forum Australia
__

What's New in progeCAD.0 to 6.4

What's New in progeCAD.4

Work with the newest DWG 2007 format

progeCAD supports the updated DWG 2007 format by opening, printing, and saving new entity types, such as annotations.

There are also many new system variables that are supported for DWG file compatibility only.

What's New in progeCAD.3

Work with DWG 2007 files

progeCAD supports opening, modifying, printing, and saving drawings in DWG 2007 format. The DWG 2007 format is now the default format in which progeCAD drawings are saved.

Create and edit color books

Now you can create and edit color books, which help you organize collections of colors, right from progeCAD.

Click for more details.

Work with images

progeCAD Professional version includes enhanced imaging features to help you work with images in your drawings. Working with images is similar as in previous progeCAD versions, with easy-to-use features located on the Image menu in progeCAD.

Click for more details.

Use new layout viewport features

There are several new features for layout viewports:

  • Snap to model space entities from paper space.
  • Lock layout viewports to lock the model space view or location while panning or zooming in paper space.
  • Assign a unique UCS to a layout viewport.

Click for more details.

Manage character sets for drawings

progeCAD allows you to manage which character set is assigned to a drawing. This unique feature can be very helpful when sharing or distributing drawings in geographic regions where several languages are used that require different character sets to display text properly.

Click for more details.

Reverse the zoom direction of the mouse wheel

Instead of zooming in and out by moving the mouse wheel forward and backward, you can reverse the settings to zoom in when spinning the mouse wheel backward and zoom out when spinning the wheel forward. This can be especially helpful if you use the mouse with your left hand.

Click for more details.

Use new and enhanced system variables

New system variables include: 3DDWFPREC, DIMARCSYM, DWGCODEPAGE, IMAGEHLT, RASTERVERNUM, RTDISPLAY, UCSVP, and ZOOMWHEEL.

Enhanced system variables include: DELOBJ, FACETRATIO, HALOGAP, HIDEPRECISION, OBSCUREDCOLOR, OBSCUREDLTYPE, OLEQUALITY, and TEXTEVAL.

There are also many new system variables that are supported for DWG file compatibility only.

What's New in progeCAD.2

Assign true colors and color book colors

You’ve always been able to add color to your drawings using index colors, but now you use two new color features:

  • True colors Defined using 24-bit color, there are more than 16 million true colors from which you can choose.
  • Color books Defined with a list of colors, color books help you organize collections of colors. For example, you can store a unique color scheme in a color book for a client and then use colors only from that color book for the client’s drawings.

Click for more details.

Work with raster images using ADeko Raster

progeCAD Professional version includes new raster imaging software to help you work with images in your drawings. Working with raster images is similar to previous progeCAD versions, with easy-to-use features located on the Image menu in progeCAD.

Click for more details.

Export to PDF and 3D DWF format

You can export drawings to two new formats:

  • PDF Portable Document Format files allow you to distribute your drawing to others for viewing with Adobe® Acrobat® Reader®, which is free software that users can download, and for viewing, reviewing, and editing with Adobe® Acrobat. Click for more details.
  • 3D DWF 3D Design Web Format files can be viewed in a Web browser if Autodesk® DWF Viewer is also installed on the computer. DWF Viewer is a free tool from Autodesk® that always supported viewing 2D DWF files, but now supports viewing DWF files in three dimensions. Click for more details.

Use entity snaps

When using the extension option with Intersection Snap and Apparent Intersection Snap, progeCAD draws dashed extension lines to help guide you as you use the extension snap option. Click for more details.

If you are working in the command bar, you can modify the active command by typing m2p or mtp to enable a one-time snap to the midpoint of two points that you specify. Click for more details.

Edit text in the command line

The command bar and Prompt History window include enhanced text editing, including cutting, copying, and pasting text; copying the last command line or the entire command history; and repeating a previously executed command.

Click for more details about the Prompt History window and click for more details about the command bar.

Create wipeout entities

Wipeouts are unique entities that can help you hide areas of your drawing. They display with the current background color, so the details behind the wipeout do not display or print. However, if your version of progeCAD does not include raster image capability (that is, does not include an Image menu), wipeout entities display, but the details behind the wipeouts also display.

Click for more details.

Create audio notes from existing *.wav files

In addition to recording audio notes in progeCAD and attaching them to entities, you can now create audio notes from existing *.wav files. Audio notes created from an existing *.wav file are saved in the drawing file and the separate *.wav file remains unchanged.

Click for more details.

View thumbnails of drawings

When you open or save a drawing, drawing files can be displayed in a number of ways, including by filename with or without the additional details. Now you can also view thumbnail images of drawing files. Click for more details.

You can also view thumbnail images when you browse drawing files on your computer using programs that came with your operating system, such as Windows® File Explorer or My Computer.

Use new and enhanced system variables

New system variables include: AUDIOICONCOLOR, NOMUTT, OSNAPCOORD, OSNAPHATCH, OSNAPZ, and RTSKIPCOUNT.

Enhanced system variables include: CECOLOR and SNAPCOLOR.

What's New in progeCAD.1

Create rendered images

progeCAD uses new and enhanced rendering features to create higher-quality and more photo-realistic images of models.

Both progeCAD Standard and progeCAD Professional include the new rendering solution, while some versions provide additional rendering capabilities with a complete set of materials, backgrounds, lighting options, and render settings.

Click for more details.

Format text

New formatting features are available when you enter text using Insert > Multiline Text. You can specify text color, first line indents, paragraph indents, right indents, and tabs.

Click for more details.

Attach and record audio

progeCAD provides the unique ability to record audio notes, which are sound clips attached to entities and available for playback at any time. For example, audio notes in a factory floor plan can describe maintenance activities for specific areas of the factory and employees can play the audio notes to hear instructions.

Click for more details.

Work with 3D solids

In addition to slicing and sectioning solids, you can now slice regions and bodies (typically sheets).

Click for more details.

Use entity snaps

You can now snap to hatch patterns when using entity snaps:

  • Snap to the middle points and end points of hatch pattern lines.
  • Snap to the nearest point and perpendicular point on a hatch pattern line.
  • Snap to any intersection point or apparent intersection point where the pattern line intersects with other entities that are supported by entity snaps.

Click for more details.

Use new system variables

New system variables include: AUDIOICON, AUDIOICONCOLOR, and AUDIOICONSCALE.

What's New in progeCAD.0

Utilize performance enhancements

Feature Performance increase
True Type Fonts
Pan
Zoom


4X (400%)
7X (700%)

Polylines
Pedit


50X (5000%)

Linetypes
Zoom extents
Pan
Regen

7X (700%)
10X (1000%)
7X (700%)

Hatch Patterns
Regen

50X (5000%)

LISP Performance
General

10X (1000%)

Blocks
Symbol table search
Regen

7X (700%)
7X (700%)
Viewports
Regen
Model space
Block display
Paper space

4X (400%)
4X (400%)
4X (400%)
3X (300%)

Assign print style tables

The following printing features have greatly enhanced your flexibility and control over the printing process:

  • Previously you could use the PenMap/Width mapping to associate colors with specific pen widths on your printer. New print style tables allow you to still specify color-based settings, but also allow you to specify pen widths, linetypes, and lineweight regardless of color.
  • Print style tables (.ctb and .stb files) are stored in files; you can share the files across multiple drawing files or with other users.

Print style tables affect numerous existing features, including: New Drawing and New Drawing Wizard; Properties and Entity Properties toolbar; Change; progeCAD Explorer (Layers); Drawing Settings > Entity Creation tab; Status bar; Options > Paths/Files tab; Options > Printing tab; and Print > Advanced tab.

There are also several new commands for print style tables: Print Style (printstyle), Print Styles Manager (stylesmanager), Convert Drawing Print Style Tables (convertpstyles), and Convert CTB Print Style Table (convertctb).

Click for more details.

Manage external references

Attaching and working with external references is now easier with the new Xref Manager. You can view a detailed list of the referenced drawing, or you can view a hierarchical display that shows how drawings are nested and related to one another. Quickly attach, detach, reload, bind, open, and change the path for all external references in the current drawing.

The Xref Manager allows you to use the same external reference features as in previous versions of progeCAD, but in a more efficient manner.

Click for more details.

Work with 3D solids

progeCAD Standard version now supports viewing and limited editing of 3D solids, including moving, rotating, and scaling. progeCAD Professional version still allows you to create and more completely edit 3D solids.

Click for more details.

Use entity snaps

The existing Intersection Snap has a new Extended option, which snaps to the logical location where two entities would intersect if they were of infinite length.

The new Apparent Intersection Snap tool snaps to the intersection of two entities that are not in the same plane but seem to intersect in the current view. You can also use its Extended option, which snaps to the logical location where two entities would intersect if they were of infinite length.

Click for more details.

Customize more options

The following features are new to the Tools > Options dialog box:

  • General tab Set the default Save As format. Specify how drawings are opened.
  • Paths/Files tab Specify search paths for print style tables.
  • Display tab Use Up/Down arrows in the command history. Show or hide the Model and Layout tabs. Show or hide scroll bars.
  • Profiles tab Create and manage drawing environment profiles.
  • Printing tab Specify headers and footers for all drawings. Assign default print style table settings for new drawings.

Click for more details.

Save and restore drawing environment profiles

Customize the settings that control your drawing environment, and then save and restore those settings in a profile. For example, if you prefer working with custom menus and toolbars, you can save these settings as your own profile.

Profiles can be helpful if you have multiple users with different preferences, or if you are a single user who works on various projects that require unique settings. You can even export your profile and bring it with you when you work on a different computer.

Click for more details.

Navigate model space and paper space

Use the enhanced Model/Paper Space control in the status bar to switch more efficiently between model space and paper space on either the Model tab or a Layout tab. Click for more details.

You can also change the display of the Model and Layout tabs in the following ways:

  • Show or hide the Model and Layout tabs. Click for more details.
  • Reorder the position of the Layout tabs. Click for more details.

Work in the command bar

In the command bar, you can do the following:

  • Select text, and then right-click to copy, cut, and paste. Click for more details.
  • Press Ctrl + K and Ctrl + L to move forward and backward in the command history. Click for more details.
  • Use the Up and Down arrows to scroll the command history, if enabled by choosing Tools > Options. Click for more details.

Choose single progeCAD sessions

Use the new Single Session command (type singleton) to choose whether progeCAD can be started one time or multiple times simultaneously.

Use new system variables

New system variables include: APBOX, CPLOTSTYLE, CTRLMOUSE, DEFLPSTYLE, DEFPLSTYLE, DEFPLSTYLETBL, FONTALT, PSTYLEMODE, PSTYLEPOLICY, MBUTTONPAN, SAVEROUNDTRIP, and SHOWTABS.

CADDIT® is a registered trademark in Australia. All Rights Reserved. Comments concerning the content of this site should be addressed to our webmaster. progeCAD is a trademark of ProgeCAD srl. Autodesk® and AutoCAD® are both registered trademarks or trademarks of a third party, and used only for comparison purposes. All other trademarks, trade names or company names referenced herein are used for identification only and are the property of their respective owners. Legal and Terms of Use. Google. Find us on Google+.