CADDIT CAD CAM CNC Software - download AutoCAD compatible design software progeCAD Alibre T-FLEX and more
CADDIT Website Knowledge Base Search:
CL

progeCAD Help

CR
Welcome to progeCAD
Working with progeCAD
Command Reference
CAD System Variables
Programming progeCAD
Full Index (caution - 400kb)

Further Links:

Download progeCAD
Register progeCAD

Learning

T-FLEX PLM tutorial (PDF)
progeCAD IntelliCAD and AutoCAD training 
CATIA 2D 3D design tutorial
Alibre CAD/CAM basic tutorial

Resources

Educational CAD Software Solutions
Python scripting for DOS and Windows
Other free software downloads
CADDIT CAD CAM Forum Australia
__

Linking objects to drawings

If another program supports ActiveX, you can link its data to progeCAD drawings. Use linking when you want to include the same data in many files. When you update the data, all links to other files reflect the changes.

For example, if you created your company logo in an ActiveX-compatible drawing program, and you want to include it in the title block of every drawing you create with progeCAD, you can link it to each progeCAD drawing. When you change the original logo in the drawing program, the progeCAD drawing updates automatically.

When you link data from another program, the progeCAD drawing stores only a reference to the location of the file in which you created the data. You link data from a saved file, so progeCAD can find the data and display it.

Because linking adds only a reference to a file, the data does not significantly increase the file size of the progeCAD drawing. However, links require some maintenance. If you move any of the linked files, you need to update the links. In addition, if you want to transport linked data, you must include all linked files.

You can update a linked object automatically every time you open the drawing or you can do so only when you specify. Anytime a link is updated, changes made to the object in its original file also appear in the progeCAD drawing, and the changes also appear in the original file if they were made through progeCAD.

To link a file to an progeCAD drawing

  1. Save the original file.
  2. Because a link consists of a reference to the original file, you must save the file before you can link to it.
  3. In the original file, select the data you want in the progeCAD drawing.
  4. Choose that program's command to place data on the Clipboard.
  5. Usually, you choose Edit > Copy.
  6. Display the progeCAD drawing to which you want to link the file.
  7. In progeCAD, choose Edit > Paste Special.
  8. In the Paste Special dialog box, select Paste Link.
  9. Click OK.

To create a linked object from within progeCAD

  1. Display the progeCAD drawing in which you want to display the linked object.
    • Choose Insert > Object
    • Type insertobj, and then press Enter.
  2. In the Insert Object dialog box, click Create From File.
  3. Specify the file by doing one of the following:
    • Type a path and file name in the File box.
    • Click Browse to select the file using a file dialog box.
  4. Select the Link check box.
  5. Select Display As Icon if you want that program's icon to appear in the drawing instead of the data.
  6. Click OK.
  7. The first page of the file appears in the progeCAD drawing, unless you chose to display it as an icon. You can select the object and drag to reposition it.

Editing an embedded or linked object from within progeCAD

Linking drawings

Edit an embedded or linked object

Link an progeCAD file to another document

CADDIT® is a registered trademark in Australia. All Rights Reserved. Comments concerning the content of this site should be addressed to our webmaster. progeCAD is a trademark of ProgeCAD srl. Autodesk® and AutoCAD® are both registered trademarks or trademarks of a third party, and used only for comparison purposes. All other trademarks, trade names or company names referenced herein are used for identification only and are the property of their respective owners. Legal and Terms of Use. Google. Find us on Google+.